wiki:FeddInstallNotes

Some notes from installing fedd on a machine at StarBED on 2011-03-15:

install them in this order:
    strongswan-4.4.0/libstrongswan
    abac
    fedd

fedd:
    ubuntu depends:
        python-zsi
        python-m2crypto
        python-pyasn1

    # get the source
    git clone git://deterlab.net/fedd
    cd fedd/fedd

    # build/install
    make
    sudo python setup.py install

abac:
    ubuntu depends:
        swig
        autoconfig-archive
        libtool

    # get the source
    git clone git://deterlab.net/abac
    cd abac

    # configure build/install
    ./autogen.sh
    ./configure --with-strongswan=$HOME/path/to/strongswan-4.4.0
    make && sudo make install

    # update system libraries
    sudo ldconfig

strongswan 4.4.0, but only libstrongswan:
    ubuntu depends:
        libgmp3-dev

    # get the file and untar
    wget http://download.strongswan.org/strongswan-4.4.0.tar.gz
    tar xzvf strongswan-4.4.0.tar.gz
    cd strongswan-4.4.0

    # configure/build/install
    ./configure --enable-monolithic
    cd src/libstrongswan
    make && sudo make install

    # update system libraries
    sudo ldconfig
Last modified 9 years ago Last modified on Apr 1, 2011 11:55:27 AM